WhyCan Forum

人过留名,雁过留声,感谢各位朋友不离不弃地支持。 QQ: 516333132, 微信: whycan_cn (哇酷网/挖坑网/填坑网) admin@whycan.cn

您尚未登录。

#1 2019-07-19 16:06:00

pqfeng
会员
注册时间: 2018-08-18
累计积分: 129

明明编译的是嵌入式版,为什么会报需要QWS的支持?

Starting network: OK
# cd V3S/
# ./TableMeet_GUI -platform linuxfb:fb=/dev/fb1
QWSSocket::connectToLocalFile could not connect:: No such file or directory
QWSSocket::connectToLocalFile could not connect:: No such file or directory
QWSSocket::connectToLocalFile could not connect:: No such file or directory
QWSSocket::connectToLocalFile could not connect:: No such file or directory
QWSSocket::connectToLocalFile could not connect:: No such file or directory
QWSSocket::connectToLocalFile could not connect:: No such file or directory
No Qt for Embedded Linux server appears to be running.
If you want to run this program as a server,
add the "-qws" command-line option.

我百度后得知,是需要要qvfb的支持。qvfb是X11或Window的啊。然后再百度,了解到说是需要在编译时加上 -embbeded arm,才可以编译出嵌入式版本。但我的编译参数是加了这个的。编译参数如下:
sudo ./configure -force-pkg-config -opensource -confirm-license -release -shared -embedded arm -xplatform arm-linux-gnueabihf -depths 4,8,16,18,24,32 -fast -optimized-qmake -no-sql-qt-libjpeg -qt-zlib -qt-libpng -qt-freetype -little-endian -host-little-endian -no-qt3support -no-libtiff -no-libmng -no-opengl -no-mmx -no-sse -no-sse2 -no-3dnow -no-openssl -no-webkit -no-qvfb -no-phonon -no-nis -no-cups -no-glib -no-xcursor -no-xfixes -no-xrandr -no-xrender -no-separate-debug-info -nomake examples -nomake tools -nomake docs -DQT_ARCH_ARM

哪位有经验的高手帮我指点一下。不胜感激。

离线

#2 2019-07-19 16:22:23

smartcar
会员
注册时间: 2018-02-19
累计积分: 429

Re: 明明编译的是嵌入式版,为什么会报需要QWS的支持?

这是Qt4 还是 Qt5?

离线

#3 2019-07-19 16:40:55

Gentlepig
会员
注册时间: 2018-10-24
累计积分: 237

Re: 明明编译的是嵌入式版,为什么会报需要QWS的支持?

qt4是-qws,qt5是-platfrom linxufb。

离线

#4 2019-07-19 17:08:03

pqfeng
会员
注册时间: 2018-08-18
累计积分: 129

Re: 明明编译的是嵌入式版,为什么会报需要QWS的支持?

你的意思是在编译时,要加上-qws?这个选项?

离线

#5 2019-07-19 17:09:29

pqfeng
会员
注册时间: 2018-08-18
累计积分: 129

Re: 明明编译的是嵌入式版,为什么会报需要QWS的支持?

可是我看到很多4的编译上都是加载-embbeded arm这个选项啊

离线

#6 2019-07-19 17:18:51

晕哥
Administrator
注册时间: 2017-09-06
累计积分: 8,476

Re: 明明编译的是嵌入式版,为什么会报需要QWS的支持?

pqfeng 说:

你的意思是在编译时,要加上-qws?这个选项?

看三楼提示:

./TableMeet_GUI -qws

离线

#7 2019-07-19 17:41:02

pqfeng
会员
注册时间: 2018-08-18
累计积分: 129

Re: 明明编译的是嵌入式版,为什么会报需要QWS的支持?

嗯是的,我加了这个,现在是其他的错误了。

离线

页脚