WhyCan Forum

本站无需注册,无需积分,无需回复可下载所有资料,如果真的喜欢小站,请您注册之后请至少回复一个帖子激活Id,谢谢支持! 站长QQ: 516333132 (挖坑网/填坑网) admin@whycan.cn

您尚未登录。

#1 2019-08-03 18:12:37

pqfeng
会员
注册时间: 2018-08-18
累计积分: 129

V3S上加Axp203电源管理芯片,导致 启动失败。。。。。无从下手啊。

按照小白菜的帖子加了相应的内容,也能probe已经运行,但运行时停止了。。。不知道问题在哪里。有大神帮忙看一下喔。。。谢谢。

[    1.051989] hy46xx_ts_init  xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[    1.059395] Successfully added driver hy46xx_ts
[    1.064529] sun6i-rtc 1c20400.rtc: rtc core: registered rtc-sun6i as rtc0
[    1.071414] sun6i-rtc 1c20400.rtc: RTC enabled
[    1.075972] i2c /dev entries driver
[    1.080859] i2c i2c-0: Failed to register i2c client  hy46xx_ts at 0x38 (-16)
[    1.088087] i2c i2c-0: of_i2c: Failure registering /soc/i2c@01c2ac00/hycon@38
[    1.095217] i2c i2c-0: Failed to create I2C device for /soc/i2c@01c2ac00/hycon@38
[    1.102900] i2c driver name i2c_device_probe  xxxxxxxxxxxxxxxxxxxxxxxxx
[    1.109548] i2c driver name = c0805534   xxxxxxxxxxxxxxxxxxxxxxxxx
[    1.115762] axp20x_i2c_probe  xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[    1.121539] axp20x-i2c 0-0034: AXP20x variant AXP209 found
[    1.134950] ldo1: supplied by regulator-dummy
[    1.139743] ldo2: supplied by regulator-dummy
[    1.145281] ldo3: supplied by regulator-dummy
[    1.150559] ldo4: supplied by regulator-dummy
[    1.155174] ldo5: supplied by regulator-dummy
[    1.160788] dcdc2: supplied by regulator-dummy
[    1.165969] dcdc3: supplied by regulator-dummy
[    1.172250] axp20x-i2c 0-0034: AXP20X driver loaded
[    1.178070] sunxi-wdt 1c20ca0.watchdog: Watchdog enabled (timeout=16 sec, nowayout=0)
[    1.187377] GPIO lookup for consumer cd
[    1.191237] GPIO lookup for consumer wp
[    1.246626] sunxi-mmc 1c0f000.mmc: base:0xc41fc000 irq:23
[    1.253684] usbcore: registered new interface driver usbhid
[    1.259359] usbhid: USB HID core driver
[    1.270652] NET: Registered protocol family 17
[    1.275209] Key type dns_resolver registered
[    1.279729] Registering SWP/SWPB emulation handler
[    1.289225] 222222222222222222222  simplefb_probe 33333333333333333333333333333
[    1.296857] simple-framebuffer 43e89000.framebuffer: framebuffer at 0x43e89000, 0x177000 bytes, mapped to 0xc4380000
[    1.307430] simple-framebuffer 43e89000.framebuffer: format=x8r8g8b8, mode=800x480x32, linelength=3200
[    1.316745] xxxxxxxxxxxxxxxxxxxxxxxxxxx  info->fix.smem_len = 1536000
[    1.331620] Console: switching to colour frame buffer device 100x30
[    1.344018] simple-framebuffer 43e89000.framebuffer: fb0: simplefb registered!
[    1.351501] GPIO lookup for consumer usb0_id_det
[    1.356177] GPIO lookup for consumer usb0_vbus_det
[    1.362110] usb_phy_generic usb_phy_generic.0.auto: usb_phy_generic.0.auto supply vcc not found, using dummy regulator
[    1.373533] musb-hdrc musb-hdrc.1.auto: MUSB HDRC host driver
[    1.379378] musb-hdrc musb-hdrc.1.auto: new USB bus registered, assigned bus number 3
[    1.389837] hub 3-0:1.0: USB hub found
[    1.395781] hub 3-0:1.0: 1 port detected
[    1.400994] using random self ethernet address
[    1.405452] using random host ethernet address
[    1.410916] usb0: HOST MAC b2:1f:47:aa:3b:a2
[    1.415232] usb0: MAC f2:50:2e:bb:35:e1
[    1.419222] g_cdc gadget: CDC Composite Gadget, version: King Kamehameha Day 2008
[    1.426737] g_cdc gadget: g_cdc ready
[    1.430679] sun6i-rtc 1c20400.rtc: setting system clock to 1970-01-01 02:20:54 UTC (8454)
[    1.439163] vcc3v0: disabling
[    1.442138] vcc5v0: disabling
[    1.445114] ldo2: disabling
[    1.4

离线

#2 2019-08-03 19:14:59

超级萌新
会员
注册时间: 2018-05-04
累计积分: 255

Re: V3S上加Axp203电源管理芯片,导致 启动失败。。。。。无从下手啊。

你没有配好吧,看 log 电源都 disable了

离线

#3 2019-08-04 09:09:02

jimmy
Moderator
注册时间: 2017-10-29
累计积分: 154

Re: V3S上加Axp203电源管理芯片,导致 启动失败。。。。。无从下手啊。

我也感觉是设备树配错了, 导致没电输出挂了。

离线

#4 2019-08-04 10:50:56

mango
会员
注册时间: 2017-12-02
累计积分: 298

Re: V3S上加Axp203电源管理芯片,导致 启动失败。。。。。无从下手啊。

这应该叫:自宫


歪朵拉开源硬件 https://widora.io/

离线

#5 2019-08-05 10:10:12

pqfeng
会员
注册时间: 2018-08-18
累计积分: 129

Re: V3S上加Axp203电源管理芯片,导致 启动失败。。。。。无从下手啊。

死机的问题找到了,并解决了。原来是我以为同一类型的设备,可以直接在设备树中。我把三种触摸芯片的内容全部写在了一起。导致起不来。现在OK了。算是验证了一个错误想法。

离线

页脚