WhyCan Forum

人过留名,雁过留声,感谢各位朋友不离不弃地支持。 QQ: 516333132, 微信: whycan_cn (哇酷网/挖坑网/填坑网) admin@whycan.cn

您尚未登录。

#1 2019-09-24 20:24:46

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

LicheePi Nano 开机显示异常


    如视频所示,在开机的试试Uboot阶段显示屏显示的LOGO挺好的,
    1.png
    但是进入Kernel阶段,首先底下会出现花屏
    2.jpeg
   接着中间会出现一条线。
   3.png

   请问是不是在Kernel阶段要配置一些参数?

离线

#2 2019-09-24 21:00:26

晕哥
Administrator
注册时间: 2017-09-06
累计积分: 8,489

Re: LicheePi Nano 开机显示异常

试一试这个固件: https://whycan.cn/t_2689.html

看看花不花

离线

#3 2019-09-24 21:33:19

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

4.png
通过这边编译重新修改dts文件,可以解决屏幕中间白条的问题

但是花屏问题,还是没有解决

离线

#4 2019-09-24 21:46:12

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

晕哥 说:

试一试这个固件: https://whycan.cn/t_2689.html

看看花不花

晕哥,用你的固件,也是有中间花屏的现象

12212.jpeg

离线

#5 2019-09-24 21:47:39

晕哥
Administrator
注册时间: 2017-09-06
累计积分: 8,489

Re: LicheePi Nano 开机显示异常

用 25 楼的这个呢: https://whycan.cn/t_2689.html#p23147

离线

#6 2019-09-24 22:07:47

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

晕哥 说:

用 25 楼的这个呢: https://whycan.cn/t_2689.html#p23147

用这个固件,开机很正常,没有出现花屏现象

离线

#7 2019-09-24 22:55:08

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

有些人的提的方案,有时间试试
https://www.cnblogs.com/skyred99/p/5684000.html

离线

#8 2019-09-24 23:21:00

xyzijk
会员
注册时间: 2019-08-23
累计积分: 14

Re: LicheePi Nano 开机显示异常

关闭背光是一种处理方式,并没有解决问题,     完全处理是需要像@路漫漫的的方式,在uboot申请高位地址内存做显示缓存区,然后将地址传递给内核,不再初始化,直接延用显示

离线

#9 2019-09-24 23:25:28

xyzijk
会员
注册时间: 2019-08-23
累计积分: 14

Re: LicheePi Nano 开机显示异常

离线

#10 2019-09-25 10:21:11

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

xyzijk 说:

关闭背光是一种处理方式,并没有解决问题,     完全处理是需要像@路漫漫的的方式,在uboot申请高位地址内存做显示缓存区,然后将地址传递给内核,不再初始化,直接延用显示

谢谢
具体方法是参考你发的链接吗
https://blog.csdn.net/spark550/article/details/79727655

是的话,我稍后试试

离线

#11 2019-09-25 11:21:08

luckymist
会员
注册时间: 2019-09-18
累计积分: 50

Re: LicheePi Nano 开机显示异常

我也遇到同样的花屏,有解吗?

离线

#12 2019-09-25 22:18:25

rayfoxjx
会员
注册时间: 2019-04-23
累计积分: 20

Re: LicheePi Nano 开机显示异常

分辨率或者颜色位数不对吧

离线

#13 2019-09-28 18:49:51

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

rayfoxjx 说:

分辨率或者颜色位数不对吧

不是这个这个原因

应该是boot跳转到kernel的时候有问题

离线

#14 2019-09-28 18:51:23

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

luckymist 说:

我也遇到同样的花屏,有解吗?

应该有解,不过还没有弄懂怎么下手

离线

#15 2019-10-22 18:52:09

xbgzy
会员
注册时间: 2019-10-07
累计积分: 19

Re: LicheePi Nano 开机显示异常

lanjackg2003 说:
luckymist 说:

我也遇到同样的花屏,有解吗?

应该有解,不过还没有弄懂怎么下手

你好,你的花屏问题解决没?

离线

#16 2019-10-30 00:00:31

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

xbgzy 说:
lanjackg2003 说:
luckymist 说:

我也遇到同样的花屏,有解吗?

应该有解,不过还没有弄懂怎么下手

你好,你的花屏问题解决没?

https://whycan.cn/p_26227.html#p26227

我重新调整分辨率,发现花屏的问题没有了
但是具体原因还不清楚

离线

#17 2019-10-30 00:24:20

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

rayfoxjx 说:

分辨率或者颜色位数不对吧

请问一下kernel下的分辨率如何跟uboot的分辨率设置成一致
目前,碰到在linux下显示的分辨率跟uboot打印的分辨率不一样
https://whycan.cn/p_26227.html#p26227

离线

#18 2019-10-30 22:50:11

lanjackg2003
会员
注册时间: 2019-06-12
累计积分: 39

Re: LicheePi Nano 开机显示异常

lanjackg2003 说:
xbgzy 说:
lanjackg2003 说:

应该有解,不过还没有弄懂怎么下手

你好,你的花屏问题解决没?

https://whycan.cn/p_26227.html#p26227

我重新调整分辨率,发现花屏的问题没有了
但是具体原因还不清楚


这方法不正确,请忽略

离线

#19 2019-11-10 11:37:22

cris8259
会员
注册时间: 2019-09-25
累计积分: 166

Re: LicheePi Nano 开机显示异常

遇到了同样的问题,花屏是怎么解决的

离线

#20 2019-11-18 22:26:37

cris8259
会员
注册时间: 2019-09-25
累计积分: 166

Re: LicheePi Nano 开机显示异常

xyzijk 说:

关闭背光是一种处理方式,并没有解决问题,     完全处理是需要像@路漫漫的的方式,在uboot申请高位地址内存做显示缓存区,然后将地址传递给内核,不再初始化,直接延用显示

你说的方式哪里有操作步骤

离线

页脚