WhyCan Forum

人过留名,雁过留声,感谢各位朋友不离不弃地支持。 QQ: 516333132 (挖坑网/填坑网) admin@whycan.cn

您尚未登录。

#1 2019-09-28 16:31:54

zero
会员
注册时间: 2019-09-12
累计积分: 33

qt移植出现位深度不支持问题

我的lcd是18位的rgb666 buildroot编译qt也是选的rgb666
运行时出现下面的问题

# ./armv7 -qws                                                                  
blit_setup(): Screen depth 32 not supported!                                    
Aborted 

离线

#2 2019-09-28 16:52:50

晕哥
Administrator
注册时间: 2017-09-06
累计积分: 7,862

Re: qt移植出现位深度不支持问题

NO, qt你应该选 32 bit, 虽然手册写着RGB666 18bit, 但是在驱动层很可能还是32bit表示有一个像素点。

离线

#3 2019-09-28 17:16:46

zero
会员
注册时间: 2019-09-12
累计积分: 33

Re: qt移植出现位深度不支持问题

是这样啊,那我吧qt,uboot都改成32bit,内核没找到

离线

#4 2019-09-28 17:30:14

zero
会员
注册时间: 2019-09-12
累计积分: 33

Re: qt移植出现位深度不支持问题

还是一样的问题,奇怪

离线

#5 2019-09-28 17:33:53

晕哥
Administrator
注册时间: 2017-09-06
累计积分: 7,862

Re: qt移植出现位深度不支持问题

zero 说:

是这样啊,那我吧qt,uboot都改成32bit,内核没找到

qt也是选的rgb666

===> RGB32

离线

#6 2019-09-28 17:49:05

zero
会员
注册时间: 2019-09-12
累计积分: 33

Re: qt移植出现位深度不支持问题

是的 有选32

 
[ ] 15 bpp, rgb 5-5-5                                            │ │  
  │ │    [ ] 16 bpp, rgb 5-6-5                                            │ │  
  │ │    [*] 18 bpp, rgb 6-6-6                                            │ │  
  │ │    [ ] 24 bpp, rgb 8-8-8                                            │ │  
  │ │    [*] 32 bpp, argb 8-8-8-8 and rgb 8-8-8                           │ │  
  │ └───────────────────────────────────────────

离线

#7 2019-09-28 18:28:23

晕哥
Administrator
注册时间: 2017-09-06
累计积分: 7,862

Re: qt移植出现位深度不支持问题

都勾上呢?

离线

#8 2019-09-28 18:33:47

zero
会员
注册时间: 2019-09-12
累计积分: 33

Re: qt移植出现位深度不支持问题

我正在尝试,下载中[============                                ]

离线

#9 2019-09-28 18:52:02

zero
会员
注册时间: 2019-09-12
累计积分: 33

Re: qt移植出现位深度不支持问题

还是不行,我clean一下试试

离线

页脚