WhyCan Forum(哇酷开发者社区)

我们能随心所欲"有问题百度(谷歌)一下", 这得感谢为中文互联网持续输出优质内容的各位老铁们。 QQ: 516333132, 微信(wechat): whycan_cn (哇酷网/挖坑网/填坑网) service@whycan.cn

您尚未登录。

#1 2018-04-05 14:33:31

kilimater
会员
注册时间: 2018-03-27
累计积分: 8

荔枝派编译问题,小白求助

荔枝派买了好久移植吃灰,自己linux小白。
按照教程荔枝派开发环境搭建
操作到了time make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- 2>&1 | tee build.log这个命令
报错
*** Your GCC is older than 6.0 and will not be supported starting in v2018.01.
  CHK     include/config/uboot.release
  CHK     include/generated/version_autogenerated.h
  CHK     include/generated/timestamp_autogenerated.h
  UPD     include/generated/timestamp_autogenerated.h
  CHK     include/generated/generic-asm-offsets.h
  CHK     include/generated/asm-offsets.h
  PYMOD   scripts/dtc/pylibfdt/_libfdt.so
unable to execute 'swig': No such file or directory
error: command 'swig' failed with exit status 1
scripts/dtc/pylibfdt/Makefile:26: recipe for target 'scripts/dtc/pylibfdt/_libfdt.so' failed
make[3]: *** [scripts/dtc/pylibfdt/_libfdt.so] Error 1
scripts/Makefile.build:425: recipe for target 'scripts/dtc/pylibfdt' failed
make[2]: *** [scripts/dtc/pylibfdt] Error 2
scripts/Makefile.build:425: recipe for target 'scripts/dtc' failed
make[1]: *** [scripts/dtc] Error 2
Makefile:491: recipe for target 'scripts' failed
make: *** [scripts] Error 2

real    0m21.847s
user    0m0.676s
sys    0m0.875s


是gcc太老了吗,不知道怎么做了
大佬帮忙看看

离线

#2 2018-04-05 14:39:14

daydayup
会员
注册时间: 2017-10-09
累计积分: 343

Re: 荔枝派编译问题,小白求助

离线

#3 2018-04-05 15:05:22

kilimater
会员
注册时间: 2018-03-27
累计积分: 8

Re: 荔枝派编译问题,小白求助

daydayup 说:

不是
是第一代荔枝派,不是zero
是A13

离线

#4 2018-04-05 15:22:30

daydayup
会员
注册时间: 2017-10-09
累计积分: 343

Re: 荔枝派编译问题,小白求助

https://whycan.cn/t_717.html
那你按照这个安装gcc 7.2.1,然后看能否编译通过,希望看到好消息。


    2) 安装arm linux 工具链:

ubuntu14.04 x64下载这个工具链: gcc-linaro-7.2.1-2017.11-x86_64_arm-eabi.tar.xz

一般解压缩到 /usr/local/ 目录,
然后把目录 export PATH=/usr/local/gcc-linaro-7.2.1-2017.11-x86_64_arm-eabi/bin:$PATH 添加到 /etc/profile, 或者 ~/.bashrc 文件

离线

#5 2018-04-05 19:12:56

kilimater
会员
注册时间: 2018-03-27
累计积分: 8

Re: 荔枝派编译问题,小白求助

daydayup 说:

https://whycan.cn/t_717.html
那你按照这个安装gcc 7.2.1,然后看能否编译通过,希望看到好消息。

谢谢大佬
看了你给的帖子,发现是swig没装
现在可以了
再次感谢

离线

#6 2018-04-05 20:20:50

daydayup
会员
注册时间: 2017-10-09
累计积分: 343

Re: 荔枝派编译问题,小白求助

swig是什么,你是用Ubuntu吗?

离线

#7 2018-04-05 21:48:08

kilimater
会员
注册时间: 2018-03-27
累计积分: 8

Re: 荔枝派编译问题,小白求助

daydayup 说:

swig是什么,你是用Ubuntu吗?

我使用的ubuntu啊,我也不知道是啥
就是这个错误
unable to execute 'swig': No such file or directory

离线

#8 2018-04-05 21:50:20

awfans
会员
注册时间: 2018-04-03
累计积分: 258

Re: 荔枝派编译问题,小白求助

kilimater 说:
daydayup 说:

swig是什么,你是用Ubuntu吗?

我使用的ubuntu啊,我也不知道是啥
就是这个错误
unable to execute 'swig': No such file or directory

那应该是新的 u-boot 编译过程中用到了 swig这个命令了。

离线

#9 2020-06-20 16:09:59

流氓兔
会员
注册时间: 2020-02-01
累计积分: 73

Re: 荔枝派编译问题,小白求助

终于解决了:

sudo apt-get install python3-distutils libpython3-dev -y

参考: https://stackoverflow.com/questions/55749206/modulenotfounderror-no-module-named-distutils-core

离线

页脚

工信部备案:粤ICP备20025096号-1 Powered by FluxBB